[SOLVED] Unable to run MongoDB Community v6.1 after installation on Apple Silicon Mac


This Content is from Stack Overflow. Question asked by AhmedAbbas

I have Mac with an Apple Silicon Chip running Monterey 12.6 and I’m trying to install MongoDB community v6.1 on it by following the steps laid out in these docs.

After completing all the steps in the installation, I am trying to run MongoDB as a background process (using the command mongod --config /opt/homebrew/etc/mongod.conf --fork), but rather than seeing a message saying it is waiting for connections on port 27017, instead I see the following error message.

about to fork child process, waiting until server is ready for connections.
forked process: 16461
ERROR: child process failed, exited with 100
To see additional information in this output, start without the "--fork" option.

Has anyone seen this before and discovered how to fix it? I have completed all the previous steps in the installation from the docs linked above.



Solution 3 on this link solved my problem.

This Question was asked in StackOverflow by AhmedAbbas and Answered by AhmedAbbas It is licensed under the terms of CC BY-SA 2.5. - CC BY-SA 3.0. - CC BY-SA 4.0.

people found this article helpful. What about you?