[SOLVED] Can’t install rospy

Issue

This Content is from Stack Overflow. Question asked by Micos

I need to use rospy for my app, and when i try to install it via pip3 install rospy or pip3 install python-rospy it results an error: ERROR: Could not find a version that satisfies the requirement python-rospy (from versions: none) ERROR: No matching distribution found for python-rospy
I have no idea how to use it and where to download it
Thanks for any responces!



Solution

There could be multiple reasons behind these errors. I think you should first check if you have ROS1 installed on your system. Since you’re going to use Python3, you’ll have to install ROS1 Noetic. You can follow the instructions mentioned on http://wiki.ros.org/noetic/Installation/Ubuntu

If you already have ROS1 Noetic on your system, you should check if you’ve source ROS1 in your .bashrc. If source /opt/ros/neotic/setup.bash is already there, then something went wrong during the installation. You should install ROS again.

Hope this helps.


This Question was asked in StackOverflow by Micos and Answered by hardesh It is licensed under the terms of CC BY-SA 2.5. - CC BY-SA 3.0. - CC BY-SA 4.0.

people found this article helpful. What about you?