atom packages install error I can’t install npm somebody help me

Issue

This Content is from Stack Overflow. Question asked by som

I am not good at using English.
So, with the help of a translator, I write the article.
So, even if my words are strange, I hope you understand.

I want to download atom package. The package you want to download is the link below.
https://atom.io/packages/script

However, the following message is displayed and the installation is not successful.

Launching Atom… If nothing happens, download Atom and try again.

I’ve tried reinstalling several times, but it didn’t work.

So, I tried to download the package manually from github by referring to the link below.
https://m.blog.naver.com/PostView.naver?isHttpsRedirect=true&blogId=9461so2&logNo=221453149316

I even managed to unzip and save the folder in /Users/user/.atom/packages/ , but after that I got the following error message.

Failed to activate the script package
Blockquote
Cannot find module ‘temp’
Require stack:

  • C:Userssom.atompackagesatom-script-masterlibgrammar-utils.js
  • C:Userssom.atompackagesatom-script-masterlibgrammarsindex.js
  • C:Userssom.atompackagesatom-script-masterlibgrammars.js
  • C:Userssom.atompackagesatom-script-masterlibcode-context-builder.js
  • C:Userssom.atompackagesatom-script-masterlibscript.js
  • C:UserssomAppDataLocalatomapp-1.60.0resourcesapp.asarstaticindex.html
    The error was thrown from the script package. You can help by creating an issue. Please explain what actions triggered this error.
    Blockquote

Here’s a copy of the error report:

> <!--
Have you read Atom's Code of Conduct? By filing an Issue, you are expected to comply with it, including treating everyone with respect: https://github.com/atom/.github/blob/master/CODE_OF_CONDUCT.md

Do you want to ask a question? Are you looking for support? The Atom message board is the best place for getting support: https://discuss.atom.io
-->

### Prerequisites

* [ ] Put an X between the brackets on this line if you have done all of the following:
    * Reproduced the problem in Safe Mode: <https://flight-manual.atom.io/hacking-atom/sections/debugging/#using-safe-mode>
    * Followed all applicable steps in the debugging guide: <https://flight-manual.atom.io/hacking-atom/sections/debugging/>
    * Checked the FAQs on the message board for common solutions: <https://discuss.atom.io/c/faq>
    * Checked that your issue isn't already filed: <https://github.com/issues?q=is%3Aissue+user%3Aatom>
    * Checked that there is not already an Atom package that provides the described functionality: <https://atom.io/packages>

### Description

<!-- Description of the issue -->

### Steps to Reproduce

1. <!-- First Step -->
2. <!-- Second Step -->
3. <!-- and so on… -->

**Expected behavior:**

<!-- What you expect to happen -->

**Actual behavior:**

<!-- What actually happens -->

### Versions

**Atom**: 1.60.0 x64
**Electron**: 9.4.4
**OS**: Unknown Windows version
**Thrown From**: [script](https://github.com/atom-ide-community/atom-script) package 3.32.2


### Stack Trace

Failed to activate the script package

```
At Cannot find module 'temp'
Require stack:
- C:Userssom.atompackagesatom-script-masterlibgrammar-utils.js
- C:Userssom.atompackagesatom-script-masterlibgrammarsindex.js
- C:Userssom.atompackagesatom-script-masterlibgrammars.js
- C:Userssom.atompackagesatom-script-masterlibcode-context-builder.js
- C:Userssom.atompackagesatom-script-masterlibscript.js
- C:UserssomAppDataLocalatomapp-1.60.0resourcesapp.asarstaticindex.html

Error: Cannot find module 'temp'
Require stack:
- C:Userssom.atompackagesatom-script-masterlibgrammar-utils.js
- C:Userssom.atompackagesatom-script-masterlibgrammarsindex.js
- C:Userssom.atompackagesatom-script-masterlibgrammars.js
- C:Userssom.atompackagesatom-script-masterlibcode-context-builder.js
- C:Userssom.atompackagesatom-script-masterlibscript.js
- C:UserssomAppDataLocalatomapp-1.60.0resourcesapp.asarstaticindex.html
    at Module._resolveFilename (internal/modules/cjs/loader.js:797:17)
    at o._resolveFilename (electron/js2c/renderer_init.js:43:689)
    at Function.get_Module._resolveFilename (~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:11:157942)
    at Module.require (/app.asar/static/index.js:61:43)
    at require (~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:11:149229)
    at /packages/atom-script-master/lib/grammar-utils.js:6:24)
    at /packages/atom-script-master/lib/grammar-utils.js:128:28)
    at Module.get_Module._compile (~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:11:149913)
    at Object.value [as .js] (~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:11:153507)
    at Module.load (internal/modules/cjs/loader.js:815:32)
    at Module._load (internal/modules/cjs/loader.js:727:14)
    at Function.Module._load (electron/js2c/asar.js:769:28)
    at Module.require (/app.asar/static/index.js:72:46)
    at require (~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:11:149229)
    at /packages/atom-script-master/lib/grammars/index.js:12:24)
    at /packages/atom-script-master/lib/grammars/index.js:614:29)
    at Module.get_Module._compile (~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:11:149913)
    at Object.value [as .js] (~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:11:153507)
    at Module.load (internal/modules/cjs/loader.js:815:32)
    at Module._load (internal/modules/cjs/loader.js:727:14)
    at Function.Module._load (electron/js2c/asar.js:769:28)
    at Module.require (/app.asar/static/index.js:72:46)
    at require (~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:11:149229)
    at /packages/atom-script-master/lib/grammars.js:11:22)
    at /packages/atom-script-master/lib/grammars.js:46:24)
    at Module.get_Module._compile (~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:11:149913)
    at Object.value [as .js] (~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:11:153507)
    at Module.load (internal/modules/cjs/loader.js:815:32)
    at Module._load (internal/modules/cjs/loader.js:727:14)
    at Function.Module._load (electron/js2c/asar.js:769:28)
    at Module.require (/app.asar/static/index.js:72:46)
    at require (~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:11:149229)
    at /packages/atom-script-master/lib/code-context-builder.js:5:41)
    at /packages/atom-script-master/lib/code-context-builder.js:135:2)
    at Module.get_Module._compile (~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:11:149913)
    at Object.value [as .js] (~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:11:153507)
    at Module.load (internal/modules/cjs/loader.js:815:32)
    at Module._load (internal/modules/cjs/loader.js:727:14)
    at Function.Module._load (electron/js2c/asar.js:769:28)
    at Module.require (/app.asar/static/index.js:72:46)
    at require (~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:11:149229)
    at /packages/atom-script-master/lib/script.js:3:43)
    at /packages/atom-script-master/lib/script.js:239:2)
    at Module.get_Module._compile (~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:11:149913)
    at Object.value [as .js] (~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:11:153507)
    at Module.load (internal/modules/cjs/loader.js:815:32)
    at Module._load (internal/modules/cjs/loader.js:727:14)
    at Function.Module._load (electron/js2c/asar.js:769:28)
    at Module.require (/app.asar/static/index.js:72:46)
    at require (internal/modules/cjs/helpers.js:74:18)
    at customRequire (~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:1:802772)
    at requireModule (~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:14:1175135)
    at Package.requireMainModule (~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:11:3543231)
    at Package.activateNow (~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:11:3531230)
    at ~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:14:2607
    at Function.simpleDispatch (~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:11:1187666)
    at Emitter.emit (~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:11:1189107)
    at PackageManager.triggerDeferredActivationHooks (~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:11:386501)
    at ~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:11:385252
    at TextEditorRegistry.updateAndMonitorEditorSettings (~/AppData/Local/atom/app-1.60.0/resources/app/static/<embedded>:11:516355)
```

### Commands

```
```

### Non-Core Packages

```
atom-beautify 0.33.4 
atom-html-preview 0.2.7 
atom-i18n 0.26.1 
script 3.32.2 
autocomplete-python 1.17.1 
color-picker 2.3.0 
emmet 2.4.3 
file-icons 2.1.47 
highlight-selected 0.17.0 
minimap 4.40.1 
minimap-highlight-selected 4.6.6 
pigments 0.40.6 
sync-settings 5.2.16 
```

### Additional Information

<!-- Any additional information, configuration or data that might be necessary to reproduce the issue. -->

After that I tried to run ndm install through terminal but got the following error:

C:Usersuser.atompackages>npm install
npm ERR! code ENOENT
npm ERR! syscall open
npm ERR! path C:Usersuser.atompackagespackage.json
npm ERR! errno -4058
npm ERR! enoent ENOENT: no such file or directory, open 'C:Usersuser.atompackagespackage.json'
npm ERR! enoent This is related to npm not being able to find a file.
npm ERR! enoent

npm ERR! A complete log of this run can be found in:
npm ERR!     C:UsersuserAppDataLocalnpm-cache_logs2022-09-18T10_04_28_405Z-debug-0.log

node.js is downloaded.

Either way is fine, so I’d like to download that package. If the download does not work, please recommend another package that can replace that package.
I want a simple package that can show the results of running code in C, Java and Python.

This is my first time using Stack Overflow.
Please let me know if I did anything wrong.



Solution

This question is not yet answered, be the first one who answer using the comment. Later the confirmed answer will be published as the solution.

This Question and Answer are collected from stackoverflow and tested by JTuto community, is licensed under the terms of CC BY-SA 2.5. - CC BY-SA 3.0. - CC BY-SA 4.0.

people found this article helpful. What about you?